連載
» 2012年12月18日 18時00分 UPDATE

Windows Server 2012 ×「ちょっとだけ連携」でネットワーク管理を便利に(1):まずは環境構築〜ネットワーク設定のおさらいを兼ねて (1/2)

Active DirectoryにDNSサーバ、DHCPサーバ、そしてスイッチやルータ……私たちを取り巻くネットワークにはさまざまなベンダの製品が混在しています。Windows Server 2012の機能を使いながらこれらにちょっとひと工夫を加え、便利に運用、管理していく方法をご紹介します。

[山口希美(エディフィストラーニング株式会社),@IT]

 多くの企業ネットワークでは、WindowsやUNIX系OS、さまざまなベンダのネットワーク機器やアプライアンスなどを、目的や用途に応じて使い分けています。これらは単体で使用することもできますが、少し設定を追加するだけで、一部の機能を連携させることができ、より便利に管理が行えるようになります。

 この連載では、大上段に構えた大がかりな連携ではなく、既存環境に少しだけ設定を追加するだけで管理の役に立つような機能を、ステップバイステップ形式でご紹介します。

 なお、本連載では「まずは検証から!」という方や、これを機にいろいろ勉強してみよう! という方向けに、サービスのインストールや初期設定からご紹介します。

まずは環境作成から

 最初に、本連載で使用する環境を構築するところから始めましょう(既存の検証環境がある方は、各デバイスのIPアドレスをご自分の環境に読み替えてください)。サーバと管理者のコンピュータは、異なるサブネットに配置されているものとします。

renkei01_01.jpg 図1

 連載では、各デバイスの設定方法を以下の順序で紹介します。今回は以下の「1. ネットワークデバイスの設定」を行い、次回、2.と3.を設定します。

  1. ネットワークデバイスの設定
  2. Active Directoryドメインコントローラの構築(連載第2回で紹介します)
  3. メンバーサーバとクライアントのドメインへの参加(連載第2回で紹介します)

ネットワークデバイスの設定

 多くの企業では、サーバと管理者のコンピュータを、異なるサブネットに配置しています。本稿でもこれに従い、サーバとクライアントを異なるサブネットに配置します。今回は、次の3つのパターンを紹介します。

  1. ルータとレイヤ2スイッチを使用する場合(シスコ)
  2. レイヤ3スイッチを使用する場合(シスコ)
  3. レイヤ3スイッチを使用する場合(アライドテレシス)

ルータとレイヤ2スイッチを使用する場合

 社内ネットワークを複数のサブネットワークに分割する場合、レイヤ3スイッチを使用することが多いと思いますが、本稿ではCiscoルータを使った場合を紹介します。

 本稿ではVLANは使用せず、次のような単純な構成にします。

renkei01_02.jpg 図2

 Ciscoルータの設定は次の通りです。

注:シスコのスイッチやルータの基本操作については、「シスコIOSの基本操作」で詳しく解説しています。


Router>enable

    特権EXECモード(すべての設定が確認できるモード)に移行します

Router#configure terminal

    グローバルコンフィギュレーションモード(設定ができるモード)に移行します

Router(config)#hostname Router1

    ルータにホスト名を設定します

Router1(config)#interface FastEthernet 0/0

    設定対象のインターフェイスを選択します

Router1(config-if)#ip address 10.1.1.254 255.255.255.0

    インターフェイスにIPアドレスを設定します

Router1(config-if)#no shutdown

    インターフェイスを有効化します

Router1(config-if)#interface FastEthernet 0/1

Router1(config-if)#ip address 10.1.2.254 255.255.255.0

Router1(config-if)#no shutdown

    同様に、もう一方のインターフェイスもIPアドレスを割り当てて、有効化します


注:太字が実際に入力するコマンド、この字は解説です。


 設定が完了したら、配線が正しいこと、ポートのLEDが緑色に点灯または点滅していることを確認し、インターフェイスの状態やルーティングテーブルを確認しておきましょう。最初に、インターフェイスの概要を一覧表示します。

renkei01_scr01.jpg
  1. インターフェイスの名前
  2. インターフェイスに割り当てられたIPアドレス
  3. インターフェイスの物理層レベルの状態
    • upは有効な状態
    • downはケーブルが接続されていないなど、無効な状態
    • administratively downはshutdownコマンドが実行されており、インターフェイスが無効化された状態
  4. インターフェイスのデータリンク層レベルの状態
    • upは有効な状態
    • downは無効な状態

 次にルーティングテーブルを確認します。各インターフェイスに割り当てたIPアドレスとサブネットマスクを基に、2つの経路情報が自動的に追加されていることが確認できます。実行結果の最後の2行に注目してください。

Router1#show ip route

(中略)

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.2.0  is directly connected, FastEthernet0/1

C       10.1.1.0  is directly connected, FastEthernet0/0


 次に、レイヤ2スイッチを設定します。レイヤ2スイッチでは、VLANを構成せずにデフォルトVLANであるVLAN1に関連付けられた状態のままにします。管理用のIPアドレスもVLAN1に割り当てます。コンピュータやルータは、レイヤ2スイッチのどのイーサネットポートに接続してもかまいません。

 以下は、L2SW1の設定例です。

Switch>enable

Switch#configure terminal

Switch(config)#hostname L2SW1

    スイッチのホスト名を「L2SW1」に設定します

L2SW1(config)#interface vlan 1

L2SW1(config-if)#ip address 10.1.1.200 255.255.255.0

    VLAN1の仮想インターフェイスにIPアドレスを割り当てます

L2SW1(config-if)#no shutdown

    VLAN1の仮想インターフェイスを有効化します

L2SW1(config-if)#exit

    グローバルコンフィギュレーションモードに戻ります

L2SW1(config)#ip default-gateway 10.1.1.254

    デフォルトゲートウェイを指定します

L2SW1(config)#exit


one point:レイヤ2スイッチとIPアドレスの関係

 レイヤ2スイッチは、MACアドレスを基に中継処理を行う機器なので、中継処理にIPアドレスは必要ありません。しかし企業向けのレイヤ2スイッチの場合、TelnetやSSHでスイッチにログインして管理を行ったり、SNMPマネージャやログ収集のためのサーバと通信したりするなど、レイヤ2スイッチそのものが送信元や宛先となって通信を行う機能が要求されます。このため、レイヤ2スイッチにもIPアドレスを割り当てて、IPホストのように通信させる機能が搭載されています。

 このとき、レイヤ2スイッチはルータとは異なるので、物理インターフェイスにIPアドレスを割り当てることはできません。レイヤ2スイッチの場合は、VLANを作成し、VLANの仮想インターフェイスにIPアドレスを割り当てるようにします。


 同様に、L2SW2の設定も行います。

Switch>enable

Switch#configure terminal

Switch(config)#hostname L2SW2

L2SW2(config)#interface vlan 1

L2SW2(config-if)#ip address 10.1.2.200 255.255.255.0

L2SW2(config-if)#no shutdown

L2SW2(config-if)#exit

L2SW2(config)#ip default-gateway 10.1.2.254

L2SW2(config)#exit


 設定が完了したら、配線が正しく行われていることを確認したうえで、スイッチからルータやサーバにpingを実行し、疎通確認を行います。以下の例では、サーバdc001に対してpingを実行しています。「!!!!!」は、pingのICMPエコーメッセージに対するエコー応答パケットが、正しく受信されたことを表します(「!」1つがエコー応答パケット1つに相当します)。

L2SW1#ping 10.1.1.254

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.254, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms


       1|2 次のページへ

Copyright© 2017 ITmedia, Inc. All Rights Reserved.

@IT Special

- PR -

TechTargetジャパン

この記事に関連するホワイトペーパー

RSSについて

アイティメディアIDについて

メールマガジン登録

@ITのメールマガジンは、 もちろん、すべて無料です。ぜひメールマガジンをご購読ください。