連載
» 2015年04月23日 05時00分 UPDATE

CCENT/CCNA 試験対策 2015年版(13):アクセスポートとトランクポート (1/2)

新米ネットワークエンジニアと共にシスコの認定資格「CCENT/CCNA」のポイントを学ぶシリーズ。今回は「スイッチに対する設定コマンド、アクセスポート、トランクポート、トランク接続、VLAN間ルーティング、DTP」について学習します。

[ドヴァ 齋藤貴幸,@IT]
title_ccent.jpg
CCENT/CCNA 試験対策 2015年版

連載目次

 新米ネットワークエンジニアのS君がCCENT/CCNAを受験するために勉強した内容をリポートに書き、S君の先輩 齋藤さんが添削する形式で進める本連載。今回の学習テーマは、シスコシステムズが発表しているCCENT試験内容の2.5「VLANによって論理的に独立したネットワークを作成する方法、およびそれらのVLAN間でのルーティングの必要性についての説明」、2.6「VLAN の設定と確認」、2.7「シスコ製スイッチのトランキングの設定と確認」の範囲から、スイッチに対する設定コマンド、アクセスポート、トランクポート、トランク接続、VLAN間ルーティング、DTPについてリポートします。


S君のリポート

i_ccent_s.jpg

 シスコシステムズ社スイッチ製品は、PCやサーバー、ルーターやスイッチなど、接続する機器に応じて、接続するポートに対し4種類の動作モードを設定できます。動作モードに対応するスイッチのポートを「アクセスポート」「トランクポート」「SVI」「ルーテッドポート」と呼びます。

 今回は、アクセスポートとトランクポートを説明します。SVIとルーテッドポートはこちらの用語解説をご覧ください。

 アクセスポートとトランクポートは、前回リポートした「VLAN」を使用する際に、スイッチのインターフェースに設定します。

アクセスポート

 アクセスポートは「一つのVLANのみを送受信できるポート」です。PCやサーバーなどのノードとの接続時は、ほぼアクセスポートに設定します。

 アクセスポートにVLANを関連付ける方法は、「スタティックVLAN」と「ダイナミックVLAN」の2種類があります。

スタティックVLAN

 スタティックVLANは、ポートのVLAN-IDをネットワーク管理者が固定的に割り当てて設定します。各ノードが所属するVLAN-IDは、つなげたポートに設定されているVLAN-IDです。VLANは接続されるノードに依存せず、スイッチのポートに関連付けられます。

 スタティックVLANは、以下のコマンドで設定します。

(config-if)# switchport mode access

(config-if)# switchport access vlan VLAN-ID


ダイナミックVLAN

 ダイナミックVLANを設定するためには、「VMPS(VLAN Management Policy Server)」と呼ばれるサーバーにMACアドレスとVLAN-IDを事前登録します。そうすると、つなげるポートが変わっても常にノードに同じVLANが割り当てられ、ノードのMACアドレスにVLANが関連付けされます。

 スタティックVLANは簡単に設定できるので、アクセスポート利用時に多く使われます。

ccent2015_13a.png 図1 アクセスポートを用いたネットワーク構成例(クリックすると、大きなサイズの画像を表示します。以降の画像も全て、クリックで拡大します)

 図1は、アクセスポートを用いたネットワーク構成例です。前回リポートで説明したように、同じVLAN-IDに属している場合のみ通信が可能です。

 図中の2台のスイッチ間で共通のVLANを通信させるためには、VLANの数だけスイッチ間を接続しなければなりません。VLANを5つ作成すればスイッチ間のケーブルも5本必要、となります。この接続方法では効率が悪いため、解決策として「トランクポート」を使用します。

トランクポート

 トランクポートは、1本のケーブルで複数のVLAN内の通信を通せるポートです。以下のコマンドでトランクポートを設定できます。

(config-if)# switchport mode trunk


ccent2015_13b.png 図2 スイッチ間のポートをトランクポートに設定した例

 図2は、スイッチ間のポートをトランクポートに設定した例です。トランクポートに設定すると、スイッチが定義しているVLANの数に依存することなく、たった1本のクロスケーブルだけでスイッチ間を接続できます。VLANの区別はアクセスポート同士をつなげたケーブルではなく、後述の「タグ」で区別します。トランクポートを用いた場合でも、VLAN-IDが異なると通信は原則できません。

トランク接続(トランクリンク)

 「トランク接続」は、スイッチ間のポートをトランクポートに設定して接続することです。

 異なるVLANのフレームを1本のケーブル内に流すトランク接続では、例えばVLAN10のフレームなのか、というように、どのVLANのフレームであるのかによってVLANを区別しなければなりません。フレームを送る際にVLAN-IDを付加することで、VLANを区別しています。VLAN-IDの付加方法として代表的なプロトコルが「IEEE802.1Q」と「ISL」です。

IEEE802.1Q

 IEEE802.1Qはタギングプロトコルと呼ばれます。イーサネットフレームにVLAN-IDが記載されている4bytesのタグを挿入して設定します。するとフレームの内容が変更されて、FCS(エラーチェック)の再計算が行われます。

ccent2015_13c.png 図3 IEEE802.1Q

ISL(Inter Switch Link)

 ISLは、イーサネットフレームをカプセル化するシスコシステムズ社独自方式のプロトコルです。イーサネットフレームの先頭に「ISLヘッダー」を、末尾に「ISLフレーム用のFCS」を付け加えて、カプセル化します。

ccent2015_13d.png 図4 ISL

 トランク接続をする際は、スイッチ間でIEEE802.1QとISLのどちらを使用するかの定義をします。定義の範囲はクロスケーブルで接続される2台のスイッチポート間に限定されます。管理者による手動設定でIEEE802.1QとISLのどちらを使用するか設定できますし、シスコシステムズ社独自の「DTP(Dynamic Trunk Protocol)」というプロトコルを用いてトランク接続する/しないの判断をスイッチ自身に任せることもできます。

 スイッチの型番によってサポートしているプロトコルが異なるため、トランク接続時は注意が必要です。現在は多くの場合、IEEE802.1Qを利用します。

VLAN間ルーティング

 「VLAN間の通信は原則できない」と述べましたが、VLAN間ルーティングの技術を使用すると、VLAN-IDの異なる場合でも通信できます。

 VLAN間ルーティングを行える機器には、「ルーター」と「レイヤー3スイッチ」があります。レイヤー3スイッチについてはCCENTとCCNAの出題範囲ではありませんのでルーターについてのみリポートします。

ccent2015_13e.png 図5 ルーターを用いてVLAN間ルーティングを利用した場合の例

 図5は、ルーターを用いてVLAN間ルーティングを利用した場合の例です。ルーターとスイッチを1台ずつ使用してVLAN間ルーティングを設定する場合、当たり前ですがどちらの機器も設定する必要があります。

 スイッチとルーターの設定手順に沿って、実際に入力したコマンドを以下に記述していきます。

スイッチの設定手順

  1. ルーターとスイッチ間のポートをトランク接続(ストレートケーブルで接続)
  2. VLANの作成
  3. スイッチポートへVLANの指定
  4. トランクポートの設定

SW> enable   特権モードへ移行

SW# conf t   グローバルコンフィギュレーションモードへ移行

VLANの作成

SW(config)# vlan 10   VLAN10の作成

SW(config-vlan)# exit

SW(config)# vlan 20   VLAN20の作成

SW(config-vlan)# exit

SW(config)#

スイッチポートへVLANの指定

SW(config)# interface fastEthernet 0/1   fa 0/1の設定モードへ移行

SW(config-if)# switchport mode access   アクセスモードを指定

SW(config-if)# switchport access vlan 10   VLAN10の指定

SW(config-if)# exit

SW(config)# interface fastEthernet 0/2   fa 0/2の設定モードへ移行

SW(config-if)# switchport mode access   アクセスモードを指定

SW(config-if)# switchport access vlan 10   VLAN10の指定

SW(config-if)# exit

SW(config)# interface fastEthernet 0/3   fa 0/3の設定モードへ移行

SW(config-if)# switchport mode access   アクセスモードを指定

SW(config-if)# switchport access vlan 20   VLAN20の指定

SW(config-if)# exit

SW(config)# interface fastEthernet 0/4   fa 0/4の設定モードへ移行

SW(config-if)# switchport mode access   アクセスモードを指定

SW(config-if)# switchport access vlan 20   VLAN20の指定

SW(config-if)# exit

SW(config)#

トランクポートの設定

SW(config)# interface fastEthernet 0/5   fa 0/5の設定モードへ移行

SW(config-if)# switchport mode trunk   トランクポートの指定

SW(config-if)# exit


 次にルーターのコマンドを解説します。以下の手順でVLAN間ルーティングを行います。

ルーターの設定手順

  1. ルーターとスイッチ間のポートをトランク接続(ストレートケーブルで接続)
  2. ルーターの物理インターフェースにVLANの数だけサブインターフェースを作成
  3. サブインターフェースにIPアドレスを付加

 使用したコマンドは以下です

RT> enable   特権モードへ移行

RT# conf t   グローバルコンフィギュレーションモード

RT(config)# interface fastEthernet 0/0   fa0/0の設定モードへ移行

RT(config-if)# no ip address   IPアドレスの無効化

RT(config-if)# no shutdown   インターフェースの有効化

RT(config-if)# exit

ルーターの物理インターフェースにVLANの数だけサブインターフェースを作成

サブインターフェースにIPアドレスを付加

RT(config)# interface fastEthernet 0/0.10   サブインターフェースfa0/0.10の作成

RT(config-if)# encapsulation dot1q 10   IEEE802.1Qの指定とVLAN10の適用

RT(config-if)# ip address 172.16.10.254 255.255.255.0   IPアドレスの設定

RT(config-if)# exit

RT(config)# interface fastEthernet 0/0.20   サブインターフェースfa0/0.20の作成

RT(config-if)# encapsulation dot1q 20   IEEE802.1Qの指定とVLAN20の適用

RT(config-if)# ip address 172.16.20.254 255.255.255.0   IPアドレスの設定

RT(config-if)# exit


用語解説

用語 意味
SVI SVIはSwitched Virtual Interfaceの略で、仮想インターフェースのことです。

レイヤー2スイッチでは、IPアドレスに代表されるレイヤー3アドレスを認識できません。このため、遠隔操作用のプロトコル(TELNETやSSH)をそのままでは使用できません。この問題を回避するために仮想インターフェースを定義して、リモートアクセスするための環境を提供します。

レイヤー2スイッチで同時に有効にできるSVIは一つのみです。SVIはVLANにひも付けされており、ひも付けされたVLANを「管理VLAN」と呼びます。初期状態では「VLAN-ID:1番」が管理VLANとして使用されます。

レイヤー3スイッチでは同時に複数のSVIを有効にできるので、後述のルーテッドポート同様にルーティングに使用します。物理ポートに依存しないSVIを使用する方が、より可用性に富んでいます。
ルーテッドポート レイヤー3スイッチで使用できるモードです。

通常はスイッチポート、トランクポートのいずれかに設定します。ルーターのインターフェースと同様に物理ポートに直接IPアドレスを設定したい場合には、ルーテッドポートとして設定します。

ルーターと同様にIPアドレスを設定するとルーティングに使えますが、可用性は前述のSVIに軍配が上がります。

※ルーテッドポートはCCNPの範囲なので、本連載の内容からは外れています。
サブインターフェース 物理インターフェースを論理的に分割するものです。VLANの数だけサブインターフェースを作成する事が一般的です。

 次回は、出題範囲の4.2「基本的なルーター設定を行うためのCLIの設定と活用方法の確認」についてリポートします。

リポート作成:新米S


齋藤さんの添削

ccent_stamp02.jpg

 初期状態のポート同士でスイッチを接続した場合、接続に使用したポートがどのモードになるかも調べてほしかったです。せっかくなので簡単に説明します。

 初期状態では「dynamic desirable」というスイッチポートのモードとなり、積極的にトランク接続しようとします。スイッチポートのモードは以下の通り設定できます。

  • Access アクセスモードに固定する
  • dynamic desirable 積極的にトランク接続しようとする(デフォルト)
  • dynamic auto 対向ポートから誘われたらトランクになる
  • trunk トランク固定
  • nonegotiate トランク固定だがDTP(トランク接続へのお誘い)を送信しない

 少しずつ難易度が上がっていますが、間違った理解をしないように注意しましょう。今回の評価も「よくできました」です。ランチはスタミナ系の豚丼でお願いします。

 齋藤

今回の宿題

 今回は宿題「なし」です。

 次回からは、S君にリポートを書いてもらうのではなく、まず私が解説し、その理解度を試すテストをS君に課す構成にリニューアル予定です。皆さんもS君と一緒に理解度を試してみてはいかがでしょうか。次回をお楽しみに。

       1|2 次のページへ

Copyright© 2017 ITmedia, Inc. All Rights Reserved.

TechTargetジャパン

この記事に関連するホワイトペーパー

RSSについて

アイティメディアIDについて

メールマガジン登録

@ITのメールマガジンは、 もちろん、すべて無料です。ぜひメールマガジンをご購読ください。