@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

Vistaで、ドメインクライアントからワークグループ共有へのアクセスに失敗する

1
投稿者投稿内容
Giyu
会議室デビュー日: 2008/04/12
投稿数: 2
お住まい・勤務地: 広島
投稿日時: 2008-04-12 16:12
はじめまして皆様、Giyuと申します。ちょっと変な構成で、知人に聞いてもよくわからないということで困っています。

1台の PC に2枚の NIC を差し、片方をドメインネットワークに接続し、もう片方をワークグループの極一般的なネットワークに接続した WindowsXP Proで、例えばドメイン側を192.168.0.10、ワークグループ側を192.168.1.10にし、ドメイン側にWANルーターがあるので、ドメイン側だけデフォルトゲートウェイを設定してインターネット接続をしていました。(それぞれクラスCネットワークで物理的に非相互接続です)

このPCには、ドメインユーザーとしてXPにログオンし、ドメイン側の共有リソースにはドメインユーザーの権限で当然そのままアクセスできますが、さらに、ワークグループ側にあるPCやTerastationなどのWindows共有フォルダにも、個々のPCなどに設定してあるユーザー情報でアクセスし、ネットワークドライブにも当然設定できました。

しかし、Vista(Business) にしたところ、ワークグループ側にあるWindows共有フォルダにはユーザー名またはパスワードが合わず、接続できないのです。
ワークグループ側にあるPC共有フォルダやTerastationなどのリソースは表示されるのですが、アクセスするときに求められる「ユーザー名とパスワード」で失敗し、入力のやりなおしダイアログを見ると、ドメイン名が勝手にユーザー名に付加されてしまっているのです。

たとえばドメイン mydomain のドメインユーザーとしてログオンしてるとき、ワークグループ側の共有フォルダのユーザー名 user パスワード pass だとすると、失敗したあとに再度入力を求められるダイアログにはユーザー名 mydomain\user みたいに、ドメイン名が勝手に付加されてしまっています。hostname\user や、WORKGROUP\user などにしても失敗します。

もしこの解決方法の手がかりなどご承知の方おられましたらご助力いただければ幸いです。

接続手順は、エクスプローラで「ネットワークドライブの割り当て」を開き、フォルダに「\\pcname\folder」あるいは「\\192.168.1.x\folder」等でUNCパスを入れ、「異なるユーザー名で接続します」をクリックして、共有フォルダ側に登録されてるユーザー名とパスを入力、「完了」をクリックしています。

よろしくおねがいします(>_<
Giyu
会議室デビュー日: 2008/04/12
投稿数: 2
お住まい・勤務地: 広島
投稿日時: 2008-04-16 08:12
自レスです。解決しましたので一応原因をば。

ドメインとか関係なく、Vistaが問題でした。
ローカルポリシーの「ネットワークセキュリティ:LAN Manager認証レベル」が「NTMv2応答のみを送信する」がデフォルトになっていたのが原因でした。
1

アイティメディアの提供サービス

ホワイトペーパー(TechTargetジャパン/閲覧には会員登録が必要です)

スキルアップ/キャリアアップ(JOB@IT)