連載
» 2008年09月11日 00時00分 公開

ネットワークの基礎を学習する CCNA対策講座(13):インターフェイスの設定とルータの初期化 (1/2)

本連載では、シスコシステムズ(以下シスコ)が提供するシスコ技術者認定(Cisco Career Certification)から、ネットワーク技術者を認定する資格、CCNA(Cisco Certified Network Associate)を解説します。CCNAは、2007年12月に改訂されたばかりで、2008年1月現在、新試験の情報がまだ少ない状況です。よって本連載は、改訂前の試験(640-801J)で解説をしますが、新試験の解説が可能になり次第、新試験(640-802J)も含めて解説していきます。

[ゴールデンフォレスト株式会社,@IT]

 今回は、ルータの主要な機能としてパケットの送受信に必要なインターフェイスの設定、ルータの初期化について解説します。

CiscoデバイスのIPアドレス設定

 ルータの主要な機能は、あるデバイスから別のデバイスにパケットを転送することです。そのため、パケットを送受信するためのインターフェイスを設定する必要があります。インターフェイスの特定コンフィグレーションモードに移行する場合は、「interface タイプ スロット/ポート」コマンドを使用します。スロット番号とポート番号は、モジュールを識別するための情報です。インターフェイスには、次のようなタイプがあります。

typeの値 タイプ
Serial シリアル
Ethernet イーサネット
FastEthernet ファストイーサネット

typeの値 タイプ
bri ISDN用(BRI)
dialer ダイヤラー
loopback ループバック


 インターフェイスにIPアドレスを設定するには、「ip address IPアドレス サブネットマスクIPアドレス サブネットマスク」コマンドを使用します。

Router(config)#interface FastEthernet 0/0
Router(config-if)#ip address 192.168.1.254 255.255.255.0

確認問題1

問題

 スロット1にあるイーサネット1のIPアドレス192.168.1.1、サブネットマスク255.255.255.0を設定するコマンドを選択しなさい。

a.Router(config)#interface Ethernet 1/1
Router(config-if)#ip address 192.168.1.1/24

b.Router(config)#interface Ethernet 1/1
Router(config-if)#ip address 192.168.1.1 255.255.255 0

c.Router(config)#interface Ethernet 1 1
Router(config-if)#ip address 192.168.1.1/255.255.255 0

d.Router(config)#interface Ethernet 1 1
Router(config-if)#ip address 192.168.1.1 255.255.255 0

正解

 b

解説

 インターフェイスのIPアドレスを設定するには、「interface タイプ スロット/ポート」コマンドにて、インターフェイスの特定コンフィグレーションモードに移行します。スロット番号とポート番号は「/」で区切って指定します。選択肢a選択肢bは、「/」で区切っているため、正しい構文ですが、選択肢c選択肢dは、空白で区切っているため不正解です。IPアドレスの指定は、「ip address IPアドレスサブネットマスク」コマンドを使用します。選択肢b選択肢dの記述は正しい構文ですが、選択肢a選択肢cのように「/」で区切って指定することはありません。モードの移行とコマンドの両方が正しいのは、選択肢bとなります。


 WAN環境では、シリアルケーブルを使用して必要なデバイスを接続します。このとき、Ciscoルータは「DTE(Data Terminal Equipment:データ端末装置)」、WAN接続デバイスを「DCE(Data Circuit-Terminating Equipment:データ回線終端装置)」と呼びます。WAN接続サービスを提供する通信業者が保有しているDCEは、クロックと呼ばれる電気信号をDTEに送って通信のタイミングを合わせます。

図1 バック to バック接続 図1 バック to バック接続

 2台のルータをシリアルケーブルで接続して、片方のルータに疑似的にDCEの役割を果たさせ、クロック設定を確認することもできます。このような接続は「バック to バック接続」と呼ばれます(図1)。

 どちらのルータがDCEの役割を持つかは、グローバルコンフィグレーションモードにて「show controllers Serial スロット/ポートスロット/ポート」コマンドを使用すれば確認できます。DCEの役割となるルータのシリアルインターフェイスに対する特定コンフィグレーションモードにて、クロックを設定するには、「clock rate クロックレートクロックレート」コマンドを使用します。シリアルインターフェイスは、回線速度を計算してあて先までの経路を決定するものがあるため、回線速度を「bandwidth 帯域幅帯域幅」コマンドにて設定することが推奨されています。

Router(config)#interface Serial 1/0
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64

       1|2 次のページへ

Copyright © ITmedia, Inc. All Rights Reserved.

RSSについて

アイティメディアIDについて

メールマガジン登録

@ITのメールマガジンは、 もちろん、すべて無料です。ぜひメールマガジンをご購読ください。