連載
» 2012年12月18日 18時00分 公開

Windows Server 2012 ×「ちょっとだけ連携」でネットワーク管理を便利に(1):まずは環境構築〜ネットワーク設定のおさらいを兼ねて (2/2)

[山口希美(エディフィストラーニング株式会社),@IT]
前のページへ 1|2       

レイヤ3スイッチを使用する場合(シスコ)

 レイヤ3スイッチを使用する場合は、VLAN(Virtual LAN)機能を使用してサーバとクライアントのサブネットを分離するため、次のような構成にします。

図3

 VLANとは、OSI参照モデルにおけるレイヤ2(データリンク層)のレベルで通信可能な範囲を区切る機能で、レイヤ2以上の企業向けスイッチ製品でサポートされています(「ネットワーク構築の基本はVLANから」を参照)。VLANを構成すると、同じVLANに関連付けられたコンピュータ同士はOSI参照モデルにおけるレイヤ2のレベルで直接通信ができますが、異なるVLAN同士は、IPなどのレイヤ3プロトコルが提供する「ルーティング機能」の助けを借りないと通信ができなくなります。

 レイヤ3スイッチは、レイヤ2スイッチの機能に加えてルーティング機能までサポートされているため、VLANを構成するだけでなく、VLAN間ルーティングまで1台のスイッチ内で行うことができます。

Switch>enable

Switch#configure terminal

Switch(config)#hostname L3SW1

L3SW1(config)#ip routing

    IPルーティング機能を有効化します

L3SW1(config)#vlan 10

    VLAN10を作成します

L3SW1(config-vlan)#name Clients

    VLAN10にClientsという名前を付けます

L3SW1(config-vlan)#vlan 20

    VLAN20を作成します

L3SW1(config-vlan)#name Servers

L3SW1(config-vlan)#exit

    VLAN20にServersという名前を付けます

L3SW1(config)#interface range FastEthernet 0/1 - 4

L3SW1(config-if-range)#switchport access vlan 10

    インターフェイスFastEthernet 0/1〜0/4をVLAN10に関連付けます

L3SW1(config-if-range)#interface range FastEthernet 0/5 - 8

L3SW1(config-if-range)#switchport access vlan 20

    同様に、0/5〜0/8をVLAN10に関連付けます

L3SW1(config-if-range)#interface vlan 10

L3SW1(config-if)# ip address 10.1.1.254 255.255.255.0

    VLAN10の仮想インターフェイスにIPアドレスとサブネットマスクを割り当てます

L3SW1(config-if)#interface vlan 20

L3SW1(config-if)# ip address 10.1.2.254 255.255.255.0

L3SW1(config-if-range)#end

    VLAN20の仮想インターフェイスにIPアドレスとサブネットマスクを割り当てます


 設定が終了したら、UTPケーブルの配線が正しく行われていることを確認し、ルーティングテーブルやポートの状態を確認しておきましょう。

 まず、VLANのポートとポートの関連付けを確認します。

 次に、ルーティングテーブルを確認します。行頭のCは、直接接続されたネットワークであることを表しています。Lは、ルータのローカルインターフェイスのIPアドレスを表します。

 本稿では、ネットワーク構成が複雑にならないようにするため、レイヤ3スイッチにコンピュータを直接接続していますが、実際の環境に近い状態を構築する場合は、次の図4のようにレイヤ3スイッチのVLAN10と20にレイヤ2スイッチを1台ずつ接続してください。レイヤ2スイッチの設定は、ネットワークデバイスの設定(Ciscoルータの場合)のレイヤ2スイッチの設定と同じです。

図4

レイヤ3スイッチを使用する場合(アライドテレシス)

 ネットワークデバイスの設定(Cisco L3スイッチの場合)と同様の構成を、アライドテレシスのレイヤ3スイッチで行う場合は、次のように設定します。

注:アライドテレシスのスイッチやルータの基本操作については、「アライドテレシスCenterCOMスイッチの基本操作」で詳しく解説しています。


図5

login: manager

  アライドテレシスのデフォルトの管理者アカウントです

Password:

  パスワードを入力します(画面上には表示されません)

Manager > enable ip

  IPモジュール(レイヤ3機能)を有効化します

Manager > create vlan=Clients vid=10

  VLAN10を作成し、Clientsという名前を付けます

Manager > create vlan=Servers vid=20

  VLAN20を作成し、Serversという名前を付けます

Manager > add vlan=10 port=1,2,3,4

  VLAN10に、ポート1〜4を割り当てます

Manager > add vlan=20 port=5,6,7,8

  VLAN20に、ポート5〜8を割り当てます

Manager > add ip interface=vlan10 ipaddress=10.1.1.254 mask=255.255.255.0

  VLAN10の仮想インターフェイスにIPアドレスとサブネットマスクを割り当てます

Manager > add ip interface=vlan20 ipaddress=10.1.2.254 mask=255.255.255.0

  VLAN20の仮想インターフェイスにIPアドレスとサブネットマスクを割り当てます


 設定が終了したら、配線が正しく行われていることを確認し、ルーティングテーブルやポートの状態を確認しておきましょう。最初にVLAN10と20に、IPアドレスが割り当てられていることを確認します。

 ルーティングテーブルを表示し、VLAN10(10.1.1.0/24)とVLAN20(10.1.2.0/24)の経路情報が登録されていることを確認します。

 ここまででネットワーク設定は完了です。次回は、Windows Server 2012を使って、ドメインコントローラやメンバーサーバを構築します。

著者プロフィール

山口 希美(やまぐち きみ)

エディフィストラーニング株式会社

ITインストラクター

エディフィストラーニング(旧社名NRIラーニングネットワーク)で、ネットワーク関連コース全般の企画・開発・実施、および書籍の執筆などを担当。同社で「理論と実装をバランスよく」をモットーに、実機演習中心のトレーニングを実施中。分かりやすさには定評がある。


前のページへ 1|2       

Copyright © ITmedia, Inc. All Rights Reserved.

RSSについて

アイティメディアIDについて

メールマガジン登録

@ITのメールマガジンは、 もちろん、すべて無料です。ぜひメールマガジンをご購読ください。