@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

ASP.NETでデバッグできない

1
投稿者投稿内容
黒コアラ
常連さん
会議室デビュー日: 2004/07/03
投稿数: 23
投稿日時: 2004-07-04 10:47
はじめまして、お世話になります。
タイトルの通りの現象に困っています。過去スレッドを読んで思い付く対応はすべてやりましたがどうにも動かないので、同じような現象を克服された方からのご助言をお願い致します。

【環境】すべて同一セグメント
クライアント:WindowsXPSP1(ドメインユーザ) VisualStudio.NET,Norton Internetsecuity
サーバ1:Windows2000serverSP4(ドメインコントローラ)トレンドマイクロウィルスバスター
サーバ2:Windows2000serverSP4(Webサーバ・リモートデバッガ用)IIS,Visual Studio.NET(サーバコンポーネントをインストール),トレンドマイクロウィルスバスター

【現象】
VB.NETによるプログラムをデバッグしようとすると下記のダイアログが表示される。

「プロジェクトを実行しようとしているときにエラーが発生しました。デバッグを開始できません。
アクセスは拒否されました。ログインしているユーザは、リモートコンピュータのDebugger Usersグループのメンバであることを確認してください。また、リモートコンピュータのDebug ManagerのDCOMの構成設定を調べてください。」

【確認事項】
・クライアントはNortonAntivirusのスクリプト遮断を切ってインストールを行った。
・クライアントのWeb.configはDebug="true"となっている。
・サーバ2のVS Developersグループ、Debugger Usersグループそれぞれに開発用ユーザのアカウント(ドメインユーザ)が追加してある。
・サーバ2にてdcomcnfg.exeを実行しMachine Debug Managerのセキュリティを確認するも、起動許可・アクセス許可共にDebugger Usersは追加&許可されている。

以上です。
サーバ2はVisual Studio.NETをインストールしてからドメインに追加しました。もう今のところ思い付く原因はそれくらいしかありません。
アドバイスやツッコミなんでも助かりますので、宜しくお願い致します。
黒コアラ
常連さん
会議室デビュー日: 2004/07/03
投稿数: 23
投稿日時: 2004-07-04 11:56
【追記】
以下にある技術情報から設定を変更してみましたが、直りませんでした。

http://support.microsoft.com/default.aspx?scid=kb;ja;821255
聖人@SKB
ベテラン
会議室デビュー日: 2003/03/26
投稿数: 58
お住まい・勤務地: 横浜(MM21)勤務の筈だがいつも顧客先常駐
投稿日時: 2004-07-05 11:02
思いつくことを1つ。
ユーザ、ASPNET(ASP.NET Machine Account)をDebugger Usersグループに
追加してみましょう。
黒コアラ
常連さん
会議室デビュー日: 2004/07/03
投稿数: 23
投稿日時: 2004-07-05 16:07
聖人@SKBさんありがとうございます。

サーバ2のAdministratorsに開発用ユーザを追加することで動くようになりました。
readmeにもその旨が明記されていたようで、見落としてしまいうかつでした。
1

スキルアップ/キャリアアップ(JOB@IT)