@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

VisualStudio2005によるDeviceApplicationの開発

1
投稿者投稿内容
nnn
会議室デビュー日: 2006/06/22
投稿数: 10
投稿日時: 2006-06-27 12:55
現在VisualStudio2005でDeviceApplicationの
システムを開発しています。

SYSTEM.DATA.SQLClientを使用してクライアントからSQLServer2000
にアクセスしたいのですが、WindowsCEのマシンで下記のエラーが
発生します。

このデバイスにインストールされているバージョンより新しいバージョンの
.NET Compact Frameworkが必要です。

詳細は

TypeLoadException
型System.Data.SqlClient,Version=1.0.5000.0,
Culture=neutral,PublicKeyToken=969DB8053D3322ACから
読み込めませんでした。

不勉強で申し訳ありませんが
よろしければお知恵を貸してください。
失礼な点がありましたらご容赦ください。
ue
ぬし
会議室デビュー日: 2005/05/07
投稿数: 581
お住まい・勤務地: 広島市
投稿日時: 2006-06-27 13:02
こんにちは。

Windows CE のマシンに .NET Compact Framework 2.0 がインストールされていないのが原因だと思います。

そうであれば、.NET Compact Framework 2.0 再頒布可能パッケージ を利用してターゲットのデバイスに .NET Compact Framework 2.0 をインストールする必要があります。
nnn
会議室デビュー日: 2006/06/22
投稿数: 10
投稿日時: 2006-06-27 15:58
ありがとうございます。

ActiveSyncを使用してデバイスの更新を行いたいのですが
別のバージョンの製品がインストールされていてうまくいきません。
どちらかのPC側で一旦削除するのでしょうか。
1

スキルアップ/キャリアアップ(JOB@IT)