@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

qmail+vpopmailでopen-smtpファイルが作成されない

1
投稿者投稿内容
Konet
会議室デビュー日: 2006/09/21
投稿数: 5
投稿日時: 2006-09-21 08:15
どなたか助言ください。。もうお手上げです。。

■■■ ./configure の結果

vpopmail directory = /home/vpopmail
uid = 509
gid = 504
roaming users = ON --enable-roaming-users
tcpserver file = /home/vpopmail/etc/tcp.smtp
open_smtp file = /home/vpopmail/etc/open-smtp
rebuild tcpserver file = ON --enable-rebuild-tcpserver-file (default)
password learning = OFF --disable-learn-passwords (default)
md5 passwords = ON --enable-md5-passwords (default)
file locking = ON --enable-file-locking (default)
vdelivermail fsync = OFF --disable-file-sync (default)
make seekable = ON --enable-make-seekable (default)
clear passwd = ON --enable-clear-passwd (default)
user dir hashing = ON --enable-users-big-dir (default)
address extensions = OFF --disable-qmail-ext (default)
ip alias = OFF --disable-ip-alias-domains (default)
auth module = cdb --enable-auth-module=cdb (default)
auth inc = -Icdb
auth lib =
system passwords = OFF --disable-passwd (default)
pop syslog = show failed attempts with clear text password
--enable-logging=p
auth logging = ON --enable-auth-logging (default)


■■■ 各ファイル構成

# ls -la /home/vpopmail/
drwxr-xr-x 8 vpopmail vchkpw 4096 9月 21 07:41 .
drwxr-xr-x 9 root root 4096 9月 10 13:54 ..
drwxr-xr-x 2 vpopmail vchkpw 4096 9月 21 07:38 bin
drwxr-xr-x 4 vpopmail vchkpw 4096 9月 9 14:03 doc
drwx------ 4 vpopmail vchkpw 4096 9月 21 07:18 domains
drwxr-xr-x 2 vpopmail vchkpw 4096 9月 21 07:19 etc
drwxr-xr-x 2 vpopmail vchkpw 4096 9月 21 07:38 include
drwxr-xr-x 2 vpopmail vchkpw 4096 9月 21 07:38 lib

# ls -la /home/vpopmail/etc/
drwxr-xr-x 2 vpopmail vchkpw 4096 9月 21 07:19 .
drwxr-xr-x 8 vpopmail vchkpw 4096 9月 21 07:41 ..
-rw-r--r-- 1 vpopmail vchkpw 25 9月 21 07:38 inc_deps
-rw-r--r-- 1 vpopmail vchkpw 42 9月 21 07:38 lib_deps
-rw-r--r-- 1 vpopmail vchkpw 26 9月 21 06:55 tcp.smtp
-rw-r--r-- 1 vpopmail vchkpw 2090 9月 21 07:19 tcp.smtp.cdb
-rw-r--r-- 1 vpopmail vchkpw 1107 9月 9 14:03 vlimits.default

■■■ 聞きたい事

/home/vpopmail/etc/ 配下に open-smtp が出来るはずですが、
なぜか出来ません。よって、メール送信時に、

553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

と言うエラーが出てしまいます。

# cat /home/vpopmail/etc/tcp.smtp
127.:allow,RELAYCLIENT=""

を、

# cat /home/vpopmail/etc/tcp.smtp
127.:allow,RELAYCLIENT=""
123.456.78.90:allow,RELAYCLIENT=""

と、クライアントのIPアドレスを明示的に許可する設定にするとメールは送れます。
以上の事から、open-smtp が作成されない事が原因で、上記のエラーに
なると結論付けました。

open-smtp が作成されない要因がお分かりの方がいましたらアドバイス頂けたら幸いです。

宜しくお願い致します。

[ メッセージ編集済み 編集者: Konet 編集日時 2006-09-21 08:31 ]

[ メッセージ編集済み 編集者: Konet 編集日時 2006-09-21 08:42 ]
Konet
会議室デビュー日: 2006/09/21
投稿数: 5
投稿日時: 2006-09-21 08:25
書き忘れたのですが、POP認証時に /var/log/maillog に何も書かれません。
もちろん /var/log/messages にも何も書かれませんでした。

引用:

# cat /home/vpopmail/etc/tcp.smtp
127.:allow,RELAYCLIENT=""
123.456.78.90:allow,RELAYCLIENT=""



上記の様に設定して、メールを送信してみると、問題なく送信時のログが /var/log/maillog にログられます。

起動スクリプトは、下記の通りです。
※生のスクリプトです。一切加工してません。

起動スクリプトに不備が原因で、open-smtp が作られなかったり maillog にログられなかったりするのでしょうか?

■■■ /var/qmail/rc の中身

#!/bin/sh

# Using splogger to send the log through syslog.
# Using qmail-local to deliver messages to ~/Mailbox by default.
PATH=/var/qmail/bin:/usr/local/bin:/bin:/usr/bin:/home/vpopmail/bin

#LANG=C
#export LANG

#QMAILQUEUE="/usr/local/bin/qmail-scanner-queue.pl"
#export QMAILQUEUE

case "$1" in
start)
echo "Starting qmail."
/var/qmail/bin/qmail-start ./Maildir/ /var/qmail/bin/splogger qmail &

# tcpserver SMTP
/usr/local/bin/tcpserver -l0 -H -R -x /home/vpopmail/etc/tcp.smtp.cdb -u 502 -g 502 0 25 \
/var/qmail/bin/qmail-smtpd 2>&1 > /dev/null &

# tcpserver POP3
/usr/local/bin/tcpserver -l0 -H -R 0 110 /var/qmail/bin/qmail-popup localhost.localdomain \
/home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir &

exit 0
;;
stop)
exec killall qmail-send
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
exit 64
;;
esac



[ メッセージ編集済み 編集者: Konet 編集日時 2006-09-21 08:31 ]
あるかな
大ベテラン
会議室デビュー日: 2003/11/04
投稿数: 245
投稿日時: 2006-09-21 09:33
おはようございます。

外れているかもしれませんが、カンで簡単に返答します。

最近の vpopmail では、

open-smtp

を touch などで事前に空作成しておく必要があったような。。。
それでもダメなら、更に cdb まで作ってあげておくとか。。。

それでもダメなら、(作成したファイルを削除して)このレスは忘れてください。

#追記
あとは、これが該当したりしますか?
http://www.psoft.net/HSdocumentation/FAQ/troubleshooter.html#Mail0


[ メッセージ編集済み 編集者: あるかな 編集日時 2006-09-21 09:35 ]
Konet
会議室デビュー日: 2006/09/21
投稿数: 5
投稿日時: 2006-09-21 13:19
お返事ありがとうございます。

引用:

最近の vpopmail では、

open-smtp

を touch などで事前に空作成しておく必要があったような。。。
それでもダメなら、更に cdb まで作ってあげておくとか。。。

それでもダメなら、(作成したファイルを削除して)このレスは忘れてください。

#追記
あとは、これが該当したりしますか?
http://www.psoft.net/HSdocumentation/FAQ/troubleshooter.html#Mail0



残念ながら、問題は解消しませんでした。

ただ、そもそもこれで問題ないのかもしれません。
と、言うのも、なぜかPOP認証時にログられない事から、POP認証が正常でない可能性があるのかな?と思ってきちゃいました(汗)
でも受信はちゃんとできるし…。

訳解らなくなってきた…。

引き続きアドバイス頂けると幸いです。
あるかな
大ベテラン
会議室デビュー日: 2003/11/04
投稿数: 245
投稿日時: 2006-09-21 21:58
あれから進展が無さそうなので、また余計なことを。

Daemontools を使っていなさそうなので、
splogger あたりでログを取ってみてはどうでしょうか?

ちなみに pop3 のログを取る場合の起動スクリプトは、
/var/qmail/bin/qmail-pop3d Maildir 2>&1 \
| /var/qmail/bin/splogger pop3d 3 &

こんな感じで編集する必要があると思います。
※引数などはご自分の環境に合わせてください。

使い方は、ここのサイトでも紹介されてます。
http://www.atmarkit.co.jp/flinux/rensai/qmail09/qmail09a.html

#追記
あと確認箇所ですが、メールを受信した直後に該当ユーザーの
メールディレクトリ直下に lastauth というファイルは生成されてますか?
または、タイムスタンプが更新されますか?

~vpopmail/domains/example.jp/username/lastauth


[ メッセージ編集済み 編集者: あるかな 編集日時 2006-09-21 22:02 ]
Konet
会議室デビュー日: 2006/09/21
投稿数: 5
投稿日時: 2006-09-21 22:32
あるかなさん、色々とありがとうございます。
結論を先に言いますと全て解決しました。

qmail vpopmail をインストールし直した所、
/home/vpopmail/etc/open-smtp が作成されてメールの送信が出来ました。

同じお悩みの方の手助けに私がやった事を書いておきます。

----------------------------------------------------

まず、再インストールする為に、既にインストールされている qmail と vpopmail の
ディレクトリ名を変えて、ダブらない様にしておく(バックアップも兼ねて)。

# mv /var/qmail /var/qmail.bak
# mv /home/vpopmail /home/vpopmail.bak

次に qmail のインストールを行う。
patchはお好みで適用。

# cd qmail-1.03
# make
# make setup check
# config-fast mail.example.com
# cp /var/qmail/boot/home /var/qmail/rc
# cd /var/qmail/alias
# touch .qmail-postmaster .qmail-mailer-daemon .qmail-root
# chmod 644 .qmail*


次に vopmail のインストールを行う

# cd vpopmail-5.4.13
# ./configure --enable-roaming-users=y --enable-relay-clear-minutes=60
# make
# make install-strip
# cd /home/vpopmail/etc/
# echo "127.:allow,RELAYCLIENT=\"\"" > tcp.smtp
# tcprules tcp.smtp.cdb tcp.smtp.tmp > tcp.smtp

起動スクリプトである /var/qmail/rc は上記に書いた通りです。

なぜ今回の様な症状になったかと言うと、色々試した結果、
一番初めの vpopmail のインストール時に、

# ./configure

と、 --enable-roaming-users=y オプションを付けてなかったのが原因でした。

何度も、

# ./configure --enable-roaming-users=y --enable-relay-clear-minutes=60
# make
# make install-strip

と、makeし直してたのですが、一度 --enable-roaming-users=y オプションなしで
インストールしてしまうと、反映されないみたいです。

なので、一度 vpopmail のディレクトリ自体を削除(リネーム)して、
新規にインストールし直してみたらうまくいきました。

あるかなさん、色々とありがとうございました。


[ メッセージ編集済み 編集者: Konet 編集日時 2006-09-22 04:42 ]
あるかな
大ベテラン
会議室デビュー日: 2003/11/04
投稿数: 245
投稿日時: 2006-09-22 09:00
おはようございます。
まずは、解決されたようでなによりです。

で、configure の変更時の話ですが、

> make distclean

で、makefile 等を掃除してくれます。

でも Konet さんの行ったディレクトリ退避方法で、
再展開方法でも良いですけどね。

とりあえず、お疲れ様でした。
Konet
会議室デビュー日: 2006/09/21
投稿数: 5
投稿日時: 2006-09-22 16:39
引用:

で、configure の変更時の話ですが、

> make distclean

で、makefile 等を掃除してくれます。



うお!はてしなく忘れてたそのコマンド・・・。
はぁ・・・・・。
1

スキルアップ/キャリアアップ(JOB@IT)