@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

Eclipse + Subversive がうまく動きません

1
投稿者投稿内容
にしやま
会議室デビュー日: 2003/12/08
投稿数: 1
投稿日時: 2007-04-27 01:39
「CoolなEclipseプラグイン(15)
 バージョン管理に便利なSubversiveプラグインの」記事を参考にして、
Eclipse3.2 + Subversive1.1.1 + trac月1.3 をインストールし、
trac月についているサンプルプロジェクトのバージョン管理ができる
ところまでこぎつけました。

そして、新しいリポジトリを作るために、コマンドラインから
create-project.bat Interlock
としたのち、Eclipseで新しいリポジトリを作りました。
(ここまではうまく言っているように見えます。)

しかしながら、そこにファイルをインポートしようとすると、
(例えば、http://localhost/svn/Interlock/ とURLを入力すると)

CHECKOUT request failed on '/svn/Interlock/!svn/ver/0/'
CHECKOUT of '/svn/Interlock/!svn/ver/0/': 400 Bad Request (http://localhost)

となって、失敗してしまいます。
自分で調べられる資料は調べて試してみましたが、うまくいきません。
どなたか、原因と対処法をご教授いただけないでしょうか。
gattaca
会議室デビュー日: 2007/05/09
投稿数: 1
お住まい・勤務地: 愛知県
投稿日時: 2007-05-09 17:04
簡単な回避策としては、使用するSVNクライアント・プラグインを、SubversiveのデフォルトのJavaSVNではなく、Native JavaHLにすれば良いと思います。
Eclipseの設定画面で、"チーム"-"SVN"を表示し、[SVNクライアント]タブの[SVNクライアント]で選択できます。
JavaSVNとSVNKitでは同じようなエラーとなるようですが、Native JavaHLだとインポートができることまでは確認できました。

当方の環境:
Eclipse 3.2.1(JBossIDE for Eclipse 2.0.0 Beta2)
Subversive 1.1.2
Trac月 1.3
1

スキルアップ/キャリアアップ(JOB@IT)