@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

Xmingを使ったXDMCP接続時でキーボードが一部使えない

1
投稿者投稿内容
かなもの
ベテラン
会議室デビュー日: 2006/08/07
投稿数: 62
投稿日時: 2007-09-02 21:51
ここには、いつもお世話になっています。

今までXmingを使い、CentOS4にXDMCP接続をして文字化けも起こらずに、特に問題なく
遠隔操作を行う事が出来ていました。

先日、Xmingのウィザードに従って、puttyを経由させてgnome-panelを実行する事で、
gnomeのメニューのみWindows側に表示出来る事がわかり、その設定を行っていました。

無事にgnome-panelのみ表示する事には成功したのですが、何かの設定を間違ったか
XDMCP接続時にキーボードが一部使用出来なくなってしまいました。
使用出来なくなったキーはエンターやスペース、シフトキーやコントロールキーなどの類全てです。
残念ながら、正確にどの様に設定していったかは、記憶が殆どありません。

ログイン画面でユーザー名とパスワードを入力し、エンターキーを押す事でログイン出来る事から、
ログイン後の問題である事が確認出来ています。

確認を行ったのは以下の内容です
・該当PC以外へのXDMCP接続
Linuxは計3台あるのですが(2台CentOS41台CentOS3)、内問題が発生したPC以外
(もう1つのCentOS4・CentOS3)には、問題なく操作が出来ます。

・Xming+puttyのgnome-panel操作
XDMCP接続では操作出来ないのですが、こちらの場合は問題なく操作が可能でした。

・該当PCで異なるユーザーにアクセス
該当PCにはrootを含めると3つのユーザーが登録されていますが、全てのユーザーで現象が出ています。

・該当PCへの直接操作
直接PCを操作する分には問題ありませんでした。

・キーの認識状態
http://www.atmarkit.co.jp/flinux/rensai/linuxtips/222dikeycode.html
ここを参考に、実際のキーの動きを確認した所、下記の状態でした。

・該当PC 直接(OK)
ButtonRelease event, serial 24, synthetic NO, window 0x1c00001,
root 0x5f, subw 0x0, time 7620490, (175,160), root:(313,745),
state 0x100, button 1, same_screen YES

KeyPress event, serial 24, synthetic NO, window 0x1c00001,
root 0x5f, subw 0x0, time 7622174, (175,160), root:(313,745),
state 0x0, keycode 36 (keysym 0xff0d, Return), same_screen YES,
" XLookupString gives 1 bytes: (0d) "
" XmbLookupString gives 1 bytes: (0d) "
XFilterEvent returns: False


・該当PC Xming(ダメ)
KeyPress event, serial 25, synthetic NO, window 0x2400001,
root 0x5b, subw 0x0, time 9336718, (174,176), root:(252,273),
state 0x0, keycode 36 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x2400001,
root 0x5b, subw 0x0, time 9336796, (174,176), root:(252,273),
state 0x0, keycode 36 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes:


・別PC Xming(OK)
KeyPress event, serial 28, synthetic NO, window 0x2e00001,
root 0x3a, subw 0x0, time 962670, (167,108), root:(172,589),
state 0x0, keycode 36 (keysym 0xff0d, Return), same_screen YES,
" XLookupString gives 1 bytes: (0d) "
" XmbLookupString gives 1 bytes: (0d) "
XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x2e00001,
root 0x3a, subw 0x0, time 962766, (167,108), root:(172,589),
state 0x0, keycode 36 (keysym 0xff0d, Return), same_screen YES,
" XLookupString gives 1 bytes: (0d) "



これらの事から、キーの情報は送られているが、それが処理されていない
という事はわかったのですが、修正する箇所を見つける事が出来ませんでした。

上記情報から、修正する箇所はおわかりになられるでしょうか。

別途必要な情報がありましたら、確認して追ってご連絡します。

よろしくお願い致します。
_________________
かなもの
ベテラン
会議室デビュー日: 2006/08/07
投稿数: 62
投稿日時: 2007-09-02 22:44
追記します。

追加で確認を行ってみました。
・別Windowsから該当PCへのXmingを使用したXDMCP接続
メインPCから接続した現象が、別PCでも発生しました。

・別LinuxPCからの該当PCへのXDMCP接続
これは問題なく操作出来ました。

この事から、Windows→LinuxへのXDMCP接続で発生する事がわかりました。
かなもの
ベテラン
会議室デビュー日: 2006/08/07
投稿数: 62
投稿日時: 2007-09-05 02:00
状況に進展がありましたので、ご報告致します。

gnomeの設定エディタを使用し、下記設定を変更した所、キーボードが動くようになりました。
/desktop/gnome/peripherals/keyboard/xkb
-----------------------
layouts = [jp]
model = jp106
overrideSettings = false
options = []
update_handlers = []
 ↓
layouts = []
model = jp106
overrideSettings = false
options = []
update_handlers = []
-----------------------

しかし、この設定変更を行うと、

 XKB 設定を利用可能にする際にエラーが発生しました。
 おそらく X サーバ内部の問題と思われます。

というエラーダイアログが、ログイン時に表示されます。

現段階では、操作不能な状態では無くなったので、致命的では無くなったのですが、
これらの理由(設定変更で動く:エラーが発生する)はお分かりになられますでしょうか。


よろしくお願い致します。

[ メッセージ編集済み 編集者: かなもの 編集日時 2007-09-05 02:02 ]
dink
会議室デビュー日: 2003/11/18
投稿数: 1
投稿日時: 2008-05-13 17:50
Xming 6.9.0.31とRHEL4.6の環境で、まったく同じ現象が起きてます。

KDEやFailsafeでログインするとまったく問題ないので、
Gnome特有の問題かも。
てつあきら
会議室デビュー日: 2008/06/26
投稿数: 1
投稿日時: 2008-06-26 01:34
-xkblayout jp
をAdditonal paramters for Xmingに設定したらうまく行きました。
かなもの
ベテラン
会議室デビュー日: 2006/08/07
投稿数: 62
投稿日時: 2008-07-12 02:26
レスありがとうございます。

情報の集め方が悪いのか、1年近く経っても現象を回避出来ていません。
(X Window SystemとGnomeを再インストールしても現象に変化無し)

現在のオプションパラメータは下記のとおりです。

・One Windows
・Open session via XDMCP
・Additonal paramters for Xming
-screen 0 1024x768 -emulate3buttons -xkbmodel jp106 -xkblayout jp -xkbvariant jp106 +bs

この設定の状況で、現象が回避出来ていません。

現在認識している使用出来ないキーは、下記の通りです。

22 BS
36 エンター
50 Shift(L)
62 Shift(R)
65 SPACE
64 Alt
109 Ctrl(R) (Ctrl(L)は使用可能)

67 F1
68 F2
69 F3
70 F4
71 F5
72 F6
73 F7
74 F8
75 F9
76 F10
95 F11
96 F12

理由がわかりません・・・なぜコードが認識してるのに
NoSymbolの状態で使用出来ないのか・・・

解決方法を知ってる方いらっしゃらないでしょうか・・・
かなもの
ベテラン
会議室デビュー日: 2006/08/07
投稿数: 62
投稿日時: 2008-08-05 12:07
お世話になっております。かなものです。

問題が発生して約1年でしょうか・・・
ようやく現象が自己解決(?)で回避され、
X Window が使用出来たのでこちらに記載したいと思います。

内容としては、Xmingのバージョン依存(?)による問題
と思われる内容でした。
自分の場合ですが、以下のように回避を行ないました。

2つのXmingのバージョンを用意しました。
Xming-20060328-setup.exe
Xming-6-9-0-31-setup.exe

まず、Xming-20060328-setup.exeをインストールします。
このバージョンでは起動すら出来ないのですが、
インストール先(デフォ:C:/Program Files/Xming)の
xkbディレクトリをバックアップしておきます。

次にXming-6-9-0-31-setup.exeをアップデートインストールします。

最後にxkbディレクトリをリネームするか消すかした後、
バックアップしてあったxkbディレクトリを、同じ場所に復元します。

この方法で、自分は問題の動作が回避出来ました。
同現象が出ている方は、自己責任の上でお試し下さい。


P.S.
新しい方は、最新の方で構わないと思うのですが、
1つ目の古い方はバージョンをあわせて貰った方が良いかもしれません。
又、Ver7が出た時点でこの作業は不要になるかもしれません。

[ メッセージ編集済み 編集者: かなもの 編集日時 2008-08-05 12:09 ]
1

スキルアップ/キャリアアップ(JOB@IT)