- PR -

1812JのNATについて

1
投稿者投稿内容
なかひろ
会議室デビュー日: 2008/06/15
投稿数: 2
投稿日時: 2008-06-15 23:30
皆様お世話になります。
お尋ねしたい事があるのですが、
下記の様な構成で、Cisco1812JでNATを行なう際に、

@   A B
OR1--| | |
|--R1--|--R2--|--SV1
| | |

@192.168.100.0/24 R1=192.168.100.10
A192.168.200.0/24 R1=192.168.200.10 R2=192.168.200.20
B192.168.0.0/24 R2=192.168.0.20
SV1=192.168.0.1
Routing=static

OR1からSV1にアクセスする際に、あたかも192.168.100.11と
言うアドレスにアクセスしたら192.168.0.1にアクセスしている
ように見せたいのですが、こういう場合はNAT-NATで対応付けを
行なうことは可能でしょうか?
例えば、telnet 192.168.100.11 とした場合にSV1にアクセス
出来るようにしたいのですが。。

ご教授頂きたく、よろしくお願いいたします。
たらお
大ベテラン
会議室デビュー日: 2006/12/25
投稿数: 206
お住まい・勤務地: 東京・永代通り
投稿日時: 2008-06-19 05:06
 (SV1):192.168.0.1◆
  |
  |192.168.0.20 F0
 [R2]
  |192.168.200.20 F1
  |
  |192.168.200.10 F1-inside
 [R1]
  |192.168.100.10(◆11) F0-outside
  |
 (OR1):192.168.100.x


では、最も簡単なパターンで。

OR1:SV1までの経路情報を、ある制限により書きたくない。
R1:SV1までの経路情報を、持っている。
R2:OR1までの経路情報を、持っている。
SV1:OR1までの経路情報を、持っている。

という前提です。

【R1設定】

interface FastEthernet0
ip address 192.168.100.10 255.255.255.0
ip nat outside

interface FastEthernet1
ip address 192.168.200.10 255.255.255.0
ip nat inside

ip nat inside source static 192.168.0.1 192.168.100.11

ip route 192.168.0.0 255.255.255.0 192.168.200.20 name 2SV1


【R2設定】
interface FastEthernet0
ip address 192.168.0.20 255.255.255.0

interface FastEthernet1
ip address 192.168.200.20 255.255.255.0

ip route 192.168.100.0 255.255.255.0 192.168.200.10 name 2OR1

以上です。ちなみに、

OR1:SV1までの経路情報を、ある制限により書きたくない。
R1:SV1までの経路情報を、ある制限により書きたくない。
R2:OR1までの経路情報を、ある制限により書きたくない。
SV1:OR1までの経路情報を、ある制限により書きたくない。

このような前提でも、NATで解決できます。


6/25 inside/outsideを修正、NAT行を修正しました。
_________________
_福田太郎_


[ メッセージ編集済み 編集者: たらお 編集日時 2008-06-25 22:25 ]
なかひろ
会議室デビュー日: 2008/06/15
投稿数: 2
投稿日時: 2008-06-21 12:14
たらおさま
元図が崩れてしまって見づらい中、分かりやすく解説頂き
感謝致します。どうもありがとうございました。

たらおさんが最後におっしゃっている途中の経路を書きたくない
場合についてなのですが、SOURCEも変更してあげないといけない
のですよね?
R1でDESTINATIONを変更した際にSOURCEの変更も行う設定とかも
あるのでしょうか?
もしNATで解決できるのであればご教授頂ければ幸いです。

どうぞよろしくお願いいたします。
たらお
大ベテラン
会議室デビュー日: 2006/12/25
投稿数: 206
お住まい・勤務地: 東京・永代通り
投稿日時: 2008-06-25 22:23
 (SV1):192.168.0.1◆
  |
  |192.168.0.20 F0
 [R2]
  |192.168.200.20 F1
  |
  |192.168.200.10(▲200) F1-inside
 [R1]
  |192.168.100.10(◆11) F0-outside
  |
 (OR1):192.168.100.x▲


前回注意点を書き忘れましたが、HTTPアプリなどで、サーバIPをNATしてしまうと、
IPベースでパスが書いてある場合に、HTTPコマンドとの整合性がなくなりますので、
DNSやHostsで調整するか、サーバNATは諦めることになります。

GET http://192.168.100.11/login.asp などというhttpデータまでは、
NATで面倒見切れないからです。


【R1設定】

interface FastEthernet0
ip address 192.168.100.10 255.255.255.0
ip nat outside

interface FastEthernet1
ip address 192.168.200.10 255.255.255.0
ip nat inside

ip nat inside source static 192.168.0.1 192.168.100.11
ip nat outside source static 192.168.100.11 192.168.200.200
! PC台数が多い場合は、ダイナミックなNATが便利でしょうか。

ip route 192.168.0.0 255.255.255.0 192.168.200.20 name 2SV1


【R2設定】
interface FastEthernet0
ip address 192.168.0.20 255.255.255.0

interface FastEthernet1
ip address 192.168.200.20 255.255.255.0

! 192.168.100.0 /24 の経路は不要です。


これなら、R2の変更なしで、目的を達成できるかと思います。


_________________
_福田太郎_

[ メッセージ編集済み 編集者: たらお 編集日時 2008-06-25 22:28 ]
1

スキルアップ/キャリアアップ(JOB@IT)