@IT会議室は、ITエンジニアに特化した質問・回答コミュニティ「QA@IT」に生まれ変わりました。ぜひご利用ください。
- PR -

Webアプリがデバッグできない。

投稿者投稿内容
はぐれコ〜ギ〜
常連さん
会議室デビュー日: 2003/06/12
投稿数: 32
投稿日時: 2003-08-14 17:31
 毎度参考にさせてもらっています。

VS.NET環境でASP.NET(VB.NET)にてWebアプリを開発しているのですが、
急に下記のようなエラーが表示されるようになり「デバッグ」や「ブラウザで表示」が
出来なくなってしまいました。
何をしたらこうなったのか心当たりが無く、原因は不明です。
ビルド/リビルドではエラーは検出されません。

この現象に関して心当たりのある方、対処法をご存知の方、ご教授お願い致しますm(__)m

□デバッグ実行時に表示されるメッセージ
引用:

サーバー アプリケーションは使用できません。
この Web サーバーでアクセスしようとしている Web アプリケーションは現在使用できません ; Web ブラウザの [更新] ボタンをクリックして再試行してください。

管理者メモ : この特定の要求エラーの原因を説明するエラー メッセージを Web サーバーのアプリケーション イベント ログで確認できます。Web サーバーのアプリケーション イベント ログを参照してエラーの原因を調べてください。



□イベントビューアーで確認できるアプリケーションエラー
引用:

aspnet_wp.exe (PID: 1748) was recycled because it failed to respond to ping message.


ウーロン
会議室デビュー日: 2003/07/29
投稿数: 10
投稿日時: 2003-08-15 17:07
はぐれコ〜ギ〜さんこんにちわ。

以前デバッグできなくなった時に
プロジェクトのプロパティ→構成プロパティ→デバッグ→
「ASP.NET デバッグを有効にする」を「True」に設定
するとデバッグできるようになりました。

私の場合の状況と違うので解決につながらないような
気もしますがとりあえずお伝えしておきます。
はぐれコ〜ギ〜
常連さん
会議室デビュー日: 2003/06/12
投稿数: 32
投稿日時: 2003-08-18 15:03
ウーロンさん、レスありがとうございます。
引用:

プロジェクトのプロパティ→構成プロパティ→デバッグ→
「ASP.NET デバッグを有効にする」を「True」に設定
するとデバッグできるようになりました。


ひとまずご報告です。

 改めてチェックをつけ、ソリューションのリビルド→デバッグとしてみたのですが、
今度はまた違った状況になってしまいました。
「デバッグ」時に空のページ(改行コードのみが数行出力される)が表示されるのです。
「ブラウザで表示」の場合も同様に空のページが表示されます。

 最近修正したファイルが原因なのかと思い、近日に修正したファイルを古いものと
入れ替えながら実行し直してみるのですが正常動作してくれません・・・
VS.NETを再インストールもしてみました。

一体何が原因なのやら・・・
Jitta
ぬし
会議室デビュー日: 2002/07/05
投稿数: 6267
お住まい・勤務地: 兵庫県・海手
投稿日時: 2003-08-18 16:21
 IISの「アプリケーション」が構成されていないとか?

IISマネージャ→目的の.aspxファイルがあるフォルダ・・・が、パッケージマーク(箱を開けて中から何かが出てきているアイコン)になっていますか?

なっていなければ右クリック→プロパティ→アプリケーションを「作成」ボタンをクリック
はぐれコ〜ギ〜
常連さん
会議室デビュー日: 2003/06/12
投稿数: 32
投稿日時: 2003-08-18 17:26
Jittaさん、レスありがとうございます。
引用:

 IISの「アプリケーション」が構成されていないとか?


後半の「空ページが表示される」という現象に関してはご指摘の部分が原因のようです。
 実は複数のプロジェクトで開発していまして、
親に当たるプロジェクトに対してはきちんとアプリ構成されていました。
逆に、アプリ構成を削除しなければいけない子プロジェクトではアプリ構成されたままでした。

その後の報告です。
1.VS.NET再インストール後、VSSより全ファイルを取得。
2.IISでのアプリケーションの構成を確認/変更。
 ・親プロジェクトではアプリ構成。
 ・子プロジェクトではアプリ構成削除。
3.ソリューションのビルド実行後、デバッグ。
→ 無事デバッグ完了!!

という事で、みなさんのお力添えのおかげで無事開発できる環境が戻ってまいりました

 しかしながら、下記のエラーメッセージが出力された1番目の現象に関しては
未だ原因が特定できておりません。
ひとまずCloseとさせて頂きますが、この現象(エラー)に関して何か情報をお持ちの方、
引き続きご教授頂きますよう宜しくお願い致します。

引用:

aspnet_wp.exe (PID: 1748) was recycled because it failed to respond to ping message.

Jitta
ぬし
会議室デビュー日: 2002/07/05
投稿数: 6267
お住まい・勤務地: 兵庫県・海手
投稿日時: 2003-08-18 19:16
引用:

はぐれコ〜ギ〜さんの書き込み (2003-08-18 17:26) より:

aspnet_wp.exe (PID: 1748) was recycled because it failed to respond to ping message.


イベントID1008ですか?私のところではイベントID1000とセットで出てきています。.NETバージョン1.0の時はイベントID1003のような?

 何らかのプロセスがaspnet_wp.exeからの返答を期待しているのに返答がないので再起動した、ということのようです。つまり、これ自身が「原因」を示していません。その前の1000、「予期せずに停止した」が、1003,1008の原因でしょう。で、1000も「停止の原因」については何も書いていないんですよね(^o^;
はぐれコ〜ギ〜
常連さん
会議室デビュー日: 2003/06/12
投稿数: 32
投稿日時: 2003-08-19 08:59
引用:

イベントID1008ですか?私のところではイベントID1000とセットで出てきています。.NETバージョン1.0の時はイベントID1003のような?


↑こいつです(^-^;
1008単独で出る場合と、1000とセットで出る場合とがあるんですがその違いは不明です・・・
結果オーライになってしまって何故今回のような現象が起きたのか、
原因が特定できていないのが懸案です。
こちらでも何かわかり次第、ご報告していきたいと思っています。
無法松
会議室デビュー日: 2003/09/08
投稿数: 1
投稿日時: 2003-09-08 21:22
全く無関係な情報かもしれませんが...

私のサーバーも突然、同じような現象になりました。
Framework 1.0 / WindowsXP / IIS 5.1 の環境です。

2日間も復旧に浪費したあげく、娘が虫垂炎。
...そんなことは関係ないですが、

その問題をMS自身が指摘しており(以下URL)、
 http://www.microsoft.com/japan/technet/treeview/default.asp?url=/japan/technet/security/bulletin/ms03-032.asp

その対処パッチもあります(以下URL)。
私はそのパッチをかませば、一発でなおりました。
 http://support.microsoft.com/default.aspx?scid=kb;ja;827641

失われた2日間を返せ!!

Framework 1.0 / WindowsXP / IIS 5.1 の環境だけが対象ですので
関係なかったら、ゴメンナサイ

スキルアップ/キャリアアップ(JOB@IT)